Is het de moeite waard om te migreren naar PHP 7.1 voor het Symfony-project?

Auteur: 4BIS Innovations | Support

Gepubliceerd: 22.01.2017

Is er een reden om de nieuwste versies van PHP te gebruiken en alle afhankelijkheden te migreren? Natuurlijk!


Onze zoektocht:


Ik keek naar de setting van het project van 1 jaar oud dat een serieuze eis stelt aan reken- en verwerkingsmiddelen. Het is een platform voor vermogensbeheer en analyses. Onze huidige setup gebruikt PHP 7.0.2. De beslissing om te migreren naar recent gepubliceerde PHP 7.1.0 (december 2016) lag niet voor de hand, want de lijst met verbeteringen is meer gericht op geheugensteuntjes en enkele aanpassingen.


Dus ik verdiepte me erin en ontdekte dat de snelheidstoename voor Symfony 2.8 ongeveer 6% zal zijn en het aantal weergegeven pagina's met 7% zal toenemen in vergelijking met PHP 7.0.2. Dat is een groot voordeel voor complexe software als deze.


Bron: www.symfony.fi


Onze opstelling is nog geavanceerder – PHP 7.2, Symfony 3.2.2


Natuurlijk moet je wat magie casten met de configuratie van Cicirle die PHP 7.1 out of the box en Heroku nog niet officieel ondersteunt.

En wat kunnen we voor jou betekenen?_

Wil je meer weten of heb je interesse? Neem dan gerust direct contact met ons op, per telefoon of via de mail.
Of maak gebruik van één van onze contactformulieren zodat we je zo snel en gepast mogelijk antwoord kunnen geven. We horen graag van je!

back to top